#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=[A-Za-z0-9])([A-Za-z0-9\h]*)(?<=[A-Za-z0-9])$"
Local $sString = "A" & @CRLF & _
"" & @CRLF & _
"Everything OK" & @CRLF & _
"" & @CRLF & _
"trailing space " & @CRLF & _
" leading space" & @CRLF & _
"" & @CRLF & _
"$leading symbol" & @CRLF & _
"trailing symbol$"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")