$re = '/^(?=[A-Za-z0-9])([A-Za-z0-9\h]*)(?<=[A-Za-z0-9])$/m';
$str = 'A
Everything OK
trailing space
leading space
$leading symbol
trailing symbol$';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);