using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=[A-Za-z0-9])([A-Za-z0-9\h]*)(?<=[A-Za-z0-9])$";
string input = @"A
Everything OK
trailing space
leading space
$leading symbol
trailing symbol$";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}