re = /^(?=[A-Za-z0-9])([A-Za-z0-9\h]*)(?<=[A-Za-z0-9])$/m
str = 'A
Everything OK
trailing space
leading space
$leading symbol
trailing symbol$'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end