using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)\s*href\s*=\s*(\""([^\""]*\"")|'[^']*'|([^'\"">]+(?=>|\s+\w+)))";
string input = @"<a href=www.example.com/1234 5678>
<a href=""recently-visited-planets.xml"" rel=""alternate"" type=""application/atom+xml"">
<a href=recently-visited-planets.xml 34566 rel=""alternate"" type=""application/atom+xml"">
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}