import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)\\s*href\\s*=\\s*(\\\"([^\\\"]*\\\")|'[^']*'|([^'\\\">]+(?=>|\\s+\\w+)))";
final String string = "<a href=www.example.com/1234 5678>\n"
+ "<a href=\"recently-visited-planets.xml\" rel=\"alternate\" type=\"application/atom+xml\">\n"
+ "<a href=recently-visited-planets.xml 34566 rel=\"alternate\" type=\"application/atom+xml\">\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}