$re = '/(?i)\s*href\s*=\s*(\"([^\"]*\")|\'[^\']*\'|([^\'\">]+(?=>|\s+\w+)))/';
$str = '<a href=www.example.com/1234 5678>
<a href="recently-visited-planets.xml" rel="alternate" type="application/atom+xml">
<a href=recently-visited-planets.xml 34566 rel="alternate" type="application/atom+xml">
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);