const regex = /(?i)\s*href\s*=\s*(\"([^\"]*\")|'[^']*'|([^'\">]+(?=>|\s+\w+)))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?i)\\s*href\\s*=\\s*(\\"([^\\"]*\\")|\'[^\']*\'|([^\'\\">]+(?=>|\\s+\\w+)))', 'g')
const str = `<a href=www.example.com/1234 5678>
<a href="recently-visited-planets.xml" rel="alternate" type="application/atom+xml">
<a href=recently-visited-planets.xml 34566 rel="alternate" type="application/atom+xml">
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}