# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\..*|[^0-9\n]//g;t' <<< "$20.00
$0.00
$10,000.00"