import Foundation
let pattern = #"\..*|[^0-9\n]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
$20.00
$0.00
$10,000.00
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)