$re = '/\..*|[^0-9\n]/';
$str = '$20.00
$0.00
$10,000.00';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;