package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\..*|[^0-9\n]`)
var str = `$20.00
$0.00
$10,000.00`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}