#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(#[a-zA-Z0-9_\-.]*)(?:[:|\s]{1})"
Local $sString = "#foobar" & @CRLF & _
"" & @CRLF & _
".body #foobar" & @CRLF & _
"" & @CRLF & _
"#foobar:hover" & @CRLF & _
"" & @CRLF & _
"#bar:hover "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")