package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(#[a-zA-Z0-9_\-.]*)(?:[:|\s]{1})`)
var str = `#foobar
.body #foobar
#foobar:hover
#bar:hover `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}