import re
regex = re.compile(r"(#[a-zA-Z0-9_\-.]*)(?:[:|\s]{1})", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("#foobar\n\n"
".body #foobar\n\n"
"#foobar:hover\n\n"
"#bar:hover ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")