re = /(#[a-zA-Z0-9_\-.]*)(?:[:|\s]{1})/mi
str = '#foobar
.body #foobar
#foobar:hover
#bar:hover '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end