# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:\G|^)(?=.*。)(?!.*,)(.*?)。/$1/gm;t' <<< "<h1>这是一个测试。<h1>
这是一个测试,这是一个测试而已,希望去掉不需要的。
测试。测试。测试。
这是一个测试,这是一个测试而已,希望去掉不需要的第二行。"