using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\G|^)(?=.*。)(?!.*,)(.*?)。";
string substitution = @"$1";
string input = @"<h1>这是一个测试。<h1>
这是一个测试,这是一个测试而已,希望去掉不需要的。
测试。测试。测试。
这是一个测试,这是一个测试而已,希望去掉不需要的第二行。";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}