const regex = /(?:\G|^)(?=.*。)(?!.*,)(.*?)。/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\G|^)(?=.*。)(?!.*,)(.*?)。', 'gm')
const str = `<h1>这是一个测试。<h1>
这是一个测试,这是一个测试而已,希望去掉不需要的。
测试。测试。测试。
这是一个测试,这是一个测试而已,希望去掉不需要的第二行。`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);