#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:\G|^)(?=.*。)(?!.*,)(.*?)。"
Local $sString = "<h1>这是一个测试。<h1>" & @CRLF & _
"这是一个测试,这是一个测试而已,希望去掉不需要的。" & @CRLF & _
"" & @CRLF & _
"测试。测试。测试。" & @CRLF & _
"这是一个测试,这是一个测试而已,希望去掉不需要的第二行。"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)