package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(<p( |.[^>])*>)(.[^<\/p>]*)(<\/p>)`)
var str = `<table><tr><td> <p class="foo">Text 1</p></td> </tr> <tr><td> <p>Text 2</p></td> </tr> <tr><td> <p>Text 3</p></td> </tr> </tr> </table>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}