$re = '/(<p( |.[^>])*>)(.[^<\/p>]*)(<\/p>)/m';
$str = '<table><tr><td> <p class="foo">Text 1</p></td> </tr> <tr><td> <p>Text 2</p></td> </tr> <tr><td> <p>Text 3</p></td> </tr> </tr> </table>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);