re = /(<p( |.[^>])*>)(.[^<\/p>]*)(<\/p>)/m
str = '<table><tr><td> <p class="foo">Text 1</p></td> </tr> <tr><td> <p>Text 2</p></td> </tr> <tr><td> <p>Text 3</p></td> </tr> </tr> </table>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end