import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<p( |.[^>])*>)(.[^<\\/p>]*)(<\\/p>)";
final String string = "<table><tr><td> <p class=\"foo\">Text 1</p></td> </tr> <tr><td> <p>Text 2</p></td> </tr> <tr><td> <p>Text 3</p></td> </tr> </tr> </table>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}