package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:09\d{8}|01\d{9}|\d{9})$`)
var str = `99819123
998191234
9981912345
01222222222
0933333333
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}