re = /^(?:09\d{8}|01\d{9}|\d{9})$/m
str = '99819123
998191234
9981912345
01222222222
0933333333
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end