$re = '/^(?:09\d{8}|01\d{9}|\d{9})$/m';
$str = '99819123
998191234
9981912345
01222222222
0933333333
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);