const regex = /^(?:09\d{8}|01\d{9}|\d{9})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:09\\d{8}|01\\d{9}|\\d{9})$', 'gm')
const str = `99819123
998191234
9981912345
01222222222
0933333333
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}