#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=(?:-?[\.0-9]{3,8}$)|(?:-?[0-9]{1,7}$))(-?[0-9]+)(?:\.([0-9]+))?$"
Local $sString = "1111.111" & @CRLF & _
"11.11" & @CRLF & _
"111.11" & @CRLF & _
"-1111.11" & @CRLF & _
"1.1111" & @CRLF & _
"11.111" & @CRLF & _
"-111.111" & @CRLF & _
"11.11" & @CRLF & _
"1111.1" & @CRLF & _
"1111.1111"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")