re = /^(?=(?:-?[\.0-9]{3,8}$)|(?:-?[0-9]{1,7}$))(-?[0-9]+)(?:\.([0-9]+))?$/m
str = '1111.111
11.11
111.11
-1111.11
1.1111
11.111
-111.111
11.11
1111.1
1111.1111'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end