import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=(?:-?[\\.0-9]{3,8}$)|(?:-?[0-9]{1,7}$))(-?[0-9]+)(?:\\.([0-9]+))?$";
final String string = "1111.111\n"
+ "11.11\n"
+ "111.11\n"
+ "-1111.11\n"
+ "1.1111\n"
+ "11.111\n"
+ "-111.111\n"
+ "11.11\n"
+ "1111.1\n"
+ "1111.1111";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}