using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=(?:-?[\.0-9]{3,8}$)|(?:-?[0-9]{1,7}$))(-?[0-9]+)(?:\.([0-9]+))?$";
string input = @"1111.111
11.11
111.11
-1111.11
1.1111
11.111
-111.111
11.11
1111.1
1111.1111";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}