using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<[^>]*?(?:(?:('|"")[^\1]*?\1)[^>]*?)*>";
string input = @"some text <tag link=""fo>o""> other text
some text <tag link=""fo>o""> other text
<meta name=""keywords"" content=""javascript,regex><><><<>,regular expression,debugger,explainer,helper,tester,match,pcre,python,editor"" />
<meta name=""descrip><>><>tion"" content=""Online reg>---<ex tester, debugger with highlighting for PHP, PCRE, Python and JavaScript."" />
<meta name=""author"" content=""Firas Dib"" />
content content content
content <meta property=""twitter:ca><<>>><>><>rd"" content=""summary"" />content content
content content
content content content <meta property=""twitter:site"" content=""@regex101"" />content content content content
content content content content
<meta property=""twitter:title"" content=""Regex101 - online regex editor and debugger"" />";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}