use strict;
my $str = 'some text <tag link="fo>o"> other text
some text <tag link="fo>o"> other text
<meta name="keywords" content="javascript,regex><><><<>,regular expression,debugger,explainer,helper,tester,match,pcre,python,editor" />
<meta name="descrip><>><>tion" content="Online reg>---<ex tester, debugger with highlighting for PHP, PCRE, Python and JavaScript." />
<meta name="author" content="Firas Dib" />
content content content
content <meta property="twitter:ca><<>>><>><>rd" content="summary" />content content
content content
content content content <meta property="twitter:site" content="@regex101" />content content content content
content content content content
<meta property="twitter:title" content="Regex101 - online regex editor and debugger" />';
my $regex = qr/<[^>]*?(?:(?:('|")[^\1]*?\1)[^>]*?)*>/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}