import re
regex = re.compile(r"<[^>]*?(?:(?:('|\")[^\1]*?\1)[^>]*?)*>")
test_str = ("some text <tag link=\"fo>o\"> other text\n"
"some text <tag link=\"fo>o\"> other text\n\n"
"<meta name=\"keywords\" content=\"javascript,regex><><><<>,regular expression,debugger,explainer,helper,tester,match,pcre,python,editor\" />\n\n"
"<meta name=\"descrip><>><>tion\" content=\"Online reg>---<ex tester, debugger with highlighting for PHP, PCRE, Python and JavaScript.\" />\n\n"
"<meta name=\"author\" content=\"Firas Dib\" />\n"
"content content content \n"
"content <meta property=\"twitter:ca><<>>><>><>rd\" content=\"summary\" />content content \n"
"content content \n"
"content content content <meta property=\"twitter:site\" content=\"@regex101\" />content content content content \n"
"content content content content \n"
"<meta property=\"twitter:title\" content=\"Regex101 - online regex editor and debugger\" />")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")