import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<[^>]*?(?:(?:('|\")[^\\1]*?\\1)[^>]*?)*>";
final String string = "some text <tag link=\"fo>o\"> other text\n"
+ "some text <tag link=\"fo>o\"> other text\n\n"
+ "<meta name=\"keywords\" content=\"javascript,regex><><><<>,regular expression,debugger,explainer,helper,tester,match,pcre,python,editor\" />\n\n"
+ "<meta name=\"descrip><>><>tion\" content=\"Online reg>---<ex tester, debugger with highlighting for PHP, PCRE, Python and JavaScript.\" />\n\n"
+ "<meta name=\"author\" content=\"Firas Dib\" />\n"
+ "content content content \n"
+ "content <meta property=\"twitter:ca><<>>><>><>rd\" content=\"summary\" />content content \n"
+ "content content \n"
+ "content content content <meta property=\"twitter:site\" content=\"@regex101\" />content content content content \n"
+ "content content content content \n"
+ "<meta property=\"twitter:title\" content=\"Regex101 - online regex editor and debugger\" />";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}