# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<table>(?:(?!chair|<\/?table>).)*chair(?:(?!<table>).)*<\/table>//s;t' <<< "<table>
<tr>
<td>
table
</td>
</tr>
</table>
<table>
<tr>
<td>
chair
</td>
</tr>
</table>
<table>
<tr>
<td>
door
</td>
</tr>
</table>"