use strict;
my $str = '<table>
<tr>
<td>
table
</td>
</tr>
</table>
<table>
<tr>
<td>
chair
</td>
</tr>
</table>
<table>
<tr>
<td>
door
</td>
</tr>
</table>';
my $regex = qr~<table>(?:(?!chair|</?table>).)*chair(?:(?!<table>).)*</table>~sp;
my $subst = '';
my $result = $str =~ s~$regex~$subst~r;
print "The result of the substitution is' $result\n";