# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<table>(?:(?!chair|</?table>).)*chair(?:(?!<table>).)*</table>"
test_str = ("<table>\n"
" <tr>\n"
" <td>\n"
" table\n"
" </td>\n"
" </tr>\n"
"</table>\n"
"<table>\n"
" <tr>\n"
" <td>\n"
" chair\n"
" </td>\n"
" </tr>\n"
"</table>\n"
"<table>\n"
" <tr>\n"
" <td>\n"
" door\n"
" </td>\n"
" </tr>\n"
"</table>")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 1, re.DOTALL)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.