re = /<table>(?:(?!chair|<\/?table>).)*chair(?:(?!<table>).)*<\/table>/
str = '<table>
<tr>
<td>
table
</td>
</tr>
</table>
<table>
<tr>
<td>
chair
</td>
</tr>
</table>
<table>
<tr>
<td>
door
</td>
</tr>
</table>'
subst = ''
result = str.sub(re, subst)
# Print the result of the substitution
puts result