using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^www\.youtube\.com\/embed\/\S*$";
string input = @"www.youtube.com/embed/tqJDf7IB4HI
www.youtube.com/embed/tqJDf7IB4HI?rel=0&controls=0
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}