$re = '/^www\.youtube\.com\/embed\/\S*$/m';
$str = 'www.youtube.com/embed/tqJDf7IB4HI
www.youtube.com/embed/tqJDf7IB4HI?rel=0&controls=0
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);