package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^www\.youtube\.com\/embed\/\S*$`)
var str = `www.youtube.com/embed/tqJDf7IB4HI
www.youtube.com/embed/tqJDf7IB4HI?rel=0&controls=0
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}