re = /^www\.youtube\.com\/embed\/\S*$/m
str = 'www.youtube.com/embed/tqJDf7IB4HI
www.youtube.com/embed/tqJDf7IB4HI?rel=0&controls=0
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end