using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([a-z0-9]+p.{1}|[a-su-z0-9]+p)t";
string input = @"aleht
happy them
tarpth
Apt
peth
tarreth
ddapdg
apples
shape the
rap them
tapeth
apth
wrap/try
sap tray
87ap9th
apothecary";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}