$re = '/^([a-z0-9]+p.{1}|[a-su-z0-9]+p)t/m';
$str = 'aleht
happy them
tarpth
Apt
peth
tarreth
ddapdg
apples
shape the
rap them
tapeth
apth
wrap/try
sap tray
87ap9th
apothecary';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);