// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([a-z0-9]+p.{1}|[a-su-z0-9]+p)t").unwrap();
let string = "aleht
happy them
tarpth
Apt
peth
tarreth
ddapdg
apples
shape the
rap them
tapeth
apth
wrap/try
sap tray
87ap9th
apothecary";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}