use strict;
my $str = 'aleht
happy them
tarpth
Apt
peth
tarreth
ddapdg
apples
shape the
rap them
tapeth
apth
wrap/try
sap tray
87ap9th
apothecary';
my $regex = qr/^([a-z0-9]+p.{1}|[a-su-z0-9]+p)t/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}