import re
regex = re.compile(r"^(([1-9]\d*(\,\d+)*(\.\d{1,4})?)|(0\.\d{1,4})|0)$", flags=re.MULTILINE)
test_str = ("2,000,000\n"
"200000.0000\n"
"200\n"
"200.00000\n"
"2,000.00\n"
"1000,000\n"
"1,000000\n"
"2,000,000\n"
"200000.0000\n"
"200\n"
"200.00000\n"
"2,000.00\n"
"2,0,00.00\n"
"1,234,456.7890\n"
"0900\n"
"0.88\n"
"0\n"
"890")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")