// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(([1-9]\d*(\,\d+)*(\.\d{1,4})?)|(0\.\d{1,4})|0)$").unwrap();
let string = "2,000,000
200000.0000
200
200.00000
2,000.00
1000,000
1,000000
2,000,000
200000.0000
200
200.00000
2,000.00
2,0,00.00
1,234,456.7890
0900
0.88
0
890";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}